Imagemagick с поддержкой Jpg в Debian Lenny

Imagemagick с поддержкой Jpg в
Debian Lenny

Или «как забороть convert: no decode delegate for this image»

Дано: сервер на Debian Lenny, где надо чтобы работал Imagemagick.

Внезапно обнаружилось, что поставленный из репозитория Imagemagick с помощью

 

apt-get install imagemagick

 

работает, но в старинной версии и без поддержки полезных форматов вроде jpg и png.

Какой выход – поставить все из исходников, видимо.

Впрочем, все ставится быстро и надежно, обычной последовательностью в виде

 

./configure
make
sudo make install

 

Но перед этим нужно скачать исходники всех нужных библиотек. Я не заморачивался новейшими их версиями, а искал в apt с помощью apt-cache search по имени нужной библиотеки

то есть, что-то вроде

 

apt-get install libjpeg62-dev libpng12-dev  libfreetype6-dev libtiff4-dev

 

... ну и что там нужно еще...

В общем, так проблема победилась. Чего всем желаю.

Всегда ваш, КО

 

Комментарии (0)

mem: 1147 total: 11 module: 6 xsl: 3